Neueste Beiträge

#1
P
Mikrocontroller / Aw: Analoges mit dem PIC
Letzter Beitrag von PICkel - Heute um 13:43:23 CEST
Hallo picass,

im DaBla zum 18F14K22, Absatz 16.3 werden max. 10kOhm als Eingangswiderstand genannt, und auf Seite 208 in Fig. 16_5 ist die Eingangsbeschaltung dargestellt.

Die 10kOhm gelten aber nur, wenn man dem PIC genügend Zeit zum Laden der internen Kondensatoren CPIN und CHOLD gibt. Da diese aber zusammen nur ca. 20pF haben, ist das für Deinen Fall unkritisch.
Mit 2...4,7 kOhm bist Du auf der sicheren Seite, auch was den Leckstrom am Pin anbelangt.

Gruß
PICkel
#2
P
Mikrocontroller / Aw: Analoges mit dem PIC
Letzter Beitrag von picass - Heute um 13:04:40 CEST
Diesen Fred führe ich mal fort, ändere aber das interne Thema. Vorher ging es um die Eingrenzung des Bereiches, in welchem an einem Port ein analoges Signal eingelesen werden kann. Das funktionierte letztlich auch sehr gut, hier zwischen 1 und 4 Volt.

Gettz was Anderes:
Wie hoch-ohmig ist so'n PIC-Port bei Verwendung als analoger Eingang. Habe in dem Datenblatt nichts darüber gefunden.
Hintergrund der Frage: in einem aktuellen Projekt - Anzeige der Regeneration des Dieselpartikelfilters - habe ich vor meinen geliebten PIC18F14K22 einen OPA335 gesetzt, in der Absicht und Annahme, dass dieser Opa als Spannungsfolger das Eingangssignal nicht belastet, am Ausgang aber den PIC gut füttern kann.

Nun stellt sich in diesem Projekt raus, dass der OPA eigene Probleme mit sich bringt, und insbesondere das Füttern des PICs auch Unerwartetes gebiert. Daher die Überlegung, den OPA gleich wegzulassen. Aber da würde ich doch gerne wissen wollen, wie hochohmig so'n PIC dabei ist, denn das Messsignal soll wirklich nicht belastet werden.
Grüße, picass
#3
P
Projekte und Eigenbau / Aw: Regeneration eines Dieselp...
Letzter Beitrag von picass - Heute um 09:41:24 CEST
Auf dem Werktisch!
Bevor aber jemand auf die Idee verfallen könnte, es läge ggf. an der Versorgungsspannung im Auto:
Nix! Im Auto ist seit Längerem meine nachgerüstete Schaltung "öltemp66" präsent, die funktioniert tadellos. Und an deren beide Uv-Anschlüsse hatte ich nun die neue Platine parallel angeklipst. Die "Öltemp" arbeitet prima, die "Regenerier" hobst zahlenmäßig. Bin aber gerade einem Verdacht auf der Spur, melde mich später noch mal.
Grüße, picass
#4
P
Video Tutorial / Aw: Löten von Litzen
Letzter Beitrag von picass - Heute um 09:36:45 CEST
Zitat von: Peter am Gestern um 18:27:27 CESTDu kannst kein 6mm2 Kabel in 2-3 Sekunden löten.
Es sei denn du nimmst eine breite Spitze und stellst eine
Temperatur von 450 Grad ein.
Hatte ich ja exakt so geschrieben: 3,5 mm Lötspitze und 400° C Löttemperatur.
Aber von armdicken Leitungen, mit welchen man ein Seeschiff am Pier befestigen könnte, war auch nie die Rede. Meine abgebildeten Lötprobs fanden an Zwillingslitze mit 0,75 mm statt. :-[ Umso verwunderlicher waren ja die unguten Ergebnisse.
Im Moment grübele ich darüber nach, meine früher schon mal errichtete, danach aber leider wieder außer Betrieb genommene sehr gute Ablüftungsanlage über meinem Werktisch wieder in Betreib zu nehmen und dann wieder auf Bleilot zurück-umzusteigen.
Grüße, picass
#5
avatar_Peter
Projekte und Eigenbau / Aw: Regeneration eines Dieselp...
Letzter Beitrag von Peter - Gestern um 19:00:59 CEST
Wo sind die Messwerte ruhig ?
Im Auto oder Zuhause ?
#6
avatar_Peter
Video Tutorial / Aw: Löten von Litzen
Letzter Beitrag von Peter - Gestern um 18:27:27 CEST
Du kannst kein 6mm2 Kabel in 2-3 Sekunden löten.
Es sei denn du nimmst eine breite Spitze und stellst eine
Temperatur von 450 Grad ein. Oder nimmst einen Gaslötkolben.
Nur wird dann von der Isolierung nichts mehr übrig bleiben.
Also alles murks. Es braucht seine Zeit bis das ganze Lötzin
komplett in die Kupferlitzen eingedrungen ist. Aber wenn du meinst du kannst
solche Kabel in der Zeit löten, dann tritt den Beweis an.
Ich lerne ja gerne immer noch was neues, wie es besser geht.
#7
P
Projekte und Eigenbau / Aw: Regeneration eines Dieselp...
Letzter Beitrag von picass - Gestern um 17:44:31 CEST
Habe einen neuen Anlauf genommen, um Ruhe in den Busch, rsp. an den PIC zu transferieren. Zunächst habe ich eine Einfachst-Gleichrichtung mit Glättung zwischen den Eingangs-OPA und den PIC geschoben. Brachte einen Fortschritt, aber die Einer-Stelle der Anzeige hobste immer noch. Dann wurde der im Plan rot gezeichnete 47 kO vom PIC-Eingang nach Masse geschaltet und seitdem ist der Busch ruhig.

Weiß nur noch nicht, ob mir diese Art der Ruhe gefällt. Dass das Eingangssignal nun um die Amplitude der Durchlass-Spannung der Schottky-Diode geschmälert wird, ist zwar bedauerlich, aber noch hinnehmbar. In der endgültigen Version der Schaltung werden eh' nur zwei Schwellwerte gebraucht, also zwei Eingangsspannungs-Werte am PIC, bei denen er jeweils eine Schaltung auslöst. Da reicht was Relatives.

Man könnte es also so belassen. Aber gibt es Vorschläge, das anders oder besser auszuführen? Könnte man den Eingangs-OP nicht als Gleichrichter beschalten, ohne dass die Amplitude leidet und der Eingang hochohmig und der Ausgang mindestens mittel-ohmig oder noch weniger ist?
Vorschläge wären was Nettes, es muss eh' schon wieder eine neue Platine angefertigt werden, und dafür könnten die Nettigkeiten gleich eingearbeitet werden.
Grüße, picass
#8
P
Video Tutorial / Aw: Löten von Litzen
Letzter Beitrag von picass - Gestern um 17:31:32 CEST
Freunde und Kupferstecher..., rsp. - Verlöter! >:(
Danke für all die Liebesmühen mit dem Video und so, aber Löten kann ich seit 50 Jahren und das ist so wie Fahrradfahren und/ oder Schwimmen: einmal oben, bleibste oben. Mal ehrlich: das Löten auf dem Video gefällt mir nicht! Viel zu lange. Lötungen sollten nach 2 bis 3 Sekunden fertig sein.

Es ist sicher die Gemengelage aus 50 Jahre alter Lötstation, deren Temp nicht direkt zu regeln ist, dem verdammten bleiblosen Lötzinn und vor allem dem Qualitätsschwund in der Litze. Mit den Reststücken der alten Litze funkt es noch. Leider habe ich gerade noch eine zweite Rolle mit dickerem Durchmesser von diesem Mist-Zwillings-Zeug entdeckt. Da werde ich mal mit Conrad ein Wörtchen reden müssen. >:(
Grüße, picass
#9
avatar_Peter
Video Tutorial / Aw: Löten von Litzen
Letzter Beitrag von Peter - Gestern um 16:59:30 CEST
Ja die war jetzt 1,6mm. Aber selbst damit geht es auch.
Da ich solche Kabel fast nie löte lohnt sich eine grösser Spitze
nicht für mich. Mit einer breiteren Spitze geht es natürlich
noch was besser.
#10
V
Video Tutorial / Aw: Löten von Litzen
Letzter Beitrag von vloki - Gestern um 16:37:24 CEST
Zum Glück ist bei mir meistens eine 3,5mm Meißelspitze drin ;)