Platine und Programm für elektrischen Garagentor-Antrieb

Begonnen von picass, 22.03.2022, 12:52:26 CET

Vorheriges Thema - Nächstes Thema

picass

Das nass-kalte Wetter motiviert mich nicht, mit dem Oszi in die Garage zu ziehen und vorher noch 4 verschiedene 230-Volt-Kabelstränge aneinander zu stöpseln und die Übergänge wasserdicht zu verpacken. Danke für eure Last-Second-Anregungen. Ich möchte freundlich darauf hinweisen, dass nicht der Betrieb des Tores zu Probs führt, sondern schlicht das Gegenteil: der Nich-Betrieb. Das Prog ist so angelegt, dass immer dann, wenn ein Endlage-Schalter oder der Handschalter (direkt an der Schaltung) oder der Schlüsselschalter (in der G-Tür) oder der Funksender einen Impuls im laufenden Betrieb=Bewegung des Tores gibt, der Motor gestoppt wird und der PIC sofort in den Schlummermodus verfällt. Und aus dem kam er zuletzt leider unaufgefordert wieder raus.

Alle 4 Schalt-Geräte landen am Port B, welcher auf Wake-on-IRQ bei Wechsel der Logik-Level (LL) eines der 4 fraglichen digitalen Eingänge eingestellt ist. Folglich käme nach meiner Logik nur ein unerwünschter LL als Störenfried in Frage oder theoretisch irgendwas Übles auf der UV - 5V - Leitung. Besondere Feuchtigkeit existiert in der G nicht. Nach einer Regenfahrt steht in der schlecht gelüfteten G wohl einige Tage eine Wasserpfütze. Aber zum Einen bewege ich den Wagen quasi nur einmal pro Woche und zum Anderen würde der Zufall der Wetterbedingung für noch längere Zeiträume der Trockenheit sorgen. An die Schaltung selbst gelangt auf keinen Fall außer Verdunstungs-Feuchte noch Dickeres.
Werde mir heute erst mal das Prog wieder rein ziehen. Das ist nun leider ein ungutes Thema. Da hatte doch unser User PICkel sich zum zweiten Male bemüht, ein Alternativ-Prog auf die Beine zu stellen, rsp. das erste Prog überarbeitet und mir in einer Mail zugestellt. Gestern beim ersten Öffnen meines Mailfaches nach dem Urlaub quoll das extrem über: Über 170 Spams, gut je 40 neue Mails unter ,,Unbekannt" und ,,Freunde". Da musste hart durchgegriffen werden, um wieder Ordnung herzustellen. Die PICkel-Mail hatte ich für den Schluss aufgehoben, um sie besonders würdigen zu können... zumal sie eine angekündigte Anlage haben sollte. Dieser Schluss kam schneller als gewollt, kurz: im Trubel des Sortierens, Löschens, Lesens war sie plötzlich weg. Mist flixter. :(
Grüße, picass

picass

#61
Mist, flixter! Habe die Schaltung in der Garage ausgebaut, in meine Werkstatt verfrachtet, den "Garagen-PIC" ( DIL-Version ) aus der Fassung gerupft und in diejenige meiner Simultan-Anlage gestöpselt. Dort tut er alles, was er tun soll, gleich von Anfang an, ohne Nachhilfe, mit allen Tastern und Kombis probiert: hier alles gut! Da bleibt wohl doch nur die Schmutzkampagne des Verlegens und Verkuppelns von Einzelkabeln, um Saft in die Garage und an den Oszi zu bekommen. :(
Mist ......, aber das sagte ich schon.....
Grüße, picass

Noch'n Nachtrag, u.a. für PICkel: Die Überstrom-Sicherung/ der Klemmschutz des Garagentors sollte nicht das Prob sein. Diese Funktion hatte ich zwar auf der Platine mit allen Bauteilen ausgebildet, die also alle aufgelötet, diese Funktion aber in der Software noch außen vor gelassen. Der entsprechende Port-Pin wurde schlicht ignoriert und nicht z.B. für den IRQ bei Portänderung zugelassen.

picass

#62
Johannes, es sieht nicht gut aus! :(
Habe heute dein neueres File ,,garagentor II" in einen PIC18F14K22 gebrannt: es ziehen zwei Relais an, der Strom-Power-Mosfet wird bemost, auch eine eigentlich unbeteiligte LED leuchtet, aber die Kette verharrt wie angekettet! In dein Basic-File habe ich auch rein geschaut, raffe aber mangels Einübung in Basic ,,nicht wirklich alles". Auch auf Tastendrücke wird nicht reagiert. Noch'n Hinweis: beim – versuchten – Start stand das ,,Tor" - in der Simul-Anlage entsprechend die beiden Magnete auf der Laufkette – in der Mitte, beide Endschalter waren also offen. Vor und nach diesem Test war der "Garagen-orig-PIC" in der IC-Fassung, in beiden Fällen lief es einwandfrei.

Bei der Gelegenheit, rsp. dem Blick in dein Programm, das möchte ich hier mal deutlich und öffentlich sagen: du hast dir eine irre Arbeit geleistet! Nein, genau wohl gleich zweimal, denn es gibt inzwischen ja zwei Versionen. Au man, Johannes! Wie soll ich dir da danken? Ich versuche es mal einfach: Danke für deine zahlreichen Bemühungen. Ich weiß, dass vier Sätze als Dank ein wenig wenig sind! :(
Grüße, picass

PICkel

Tut mir leid, Bernd!
Es musste alles ziemlich schnell gehen. Ich war mir meiner Sache ziemlich sicher, deshalb habe ich keinen Test auf dem Testboard durchgeführt.

Alles Weitere per PN
Gruß
Johannes

picass

Macht nichts, wenn es hier beschaulich weiter gehen sollte. Das Garagentor wird halt von Hand geöffnet und da ich - wie schon mal gesagt - den dicken Sechszylinder in der Woche fast überhaupt nicht mehr anfasse, sondern stattdessen mit Behagen auf meinen E-Roller klettere, gibts wirklich keinerlei Anlass für Hektik. Ähm... meine Frau sieht das anders, aber die wird unterdrückt! >:D Zumindest in diesem Punkt! ;)
Muss selbst auch noch sämtliche Grundlagen der Hardware und meines Progs neu durcharbeiten, das dauert sowieso.
Grüße, Bernd

picass

Habe in den letzten Tagen die Garagen-Steuerungs-Anlage ausgebaut und in meiner Werkstatt betrachtet. Zudem wurden diverse Tests mit der Simul-Anlage ausgeführt. Heute wurde noch der Funk-Empfänger aus der G geholt und hier gründlich untersucht. Leider alles toll in Ordnung! :)
 >:(

Kein Fehlverhalten zu finden, auch nicht mit dem Oszi im F-Empfänger!
Mist, wie soll man gegen Fehler ankämpfen, die sich verstecken?!

Einzig gefunden: der Port A ist komplett als Eingang geschaltet und der einzige, nicht benutzte Pin A2 war extern unbeschaltet. Allerdings wurde der weder abgefragt und war auch beim wake-up bei Port-Change vom IRQ ausgeschlossen, zudem war für den der interne pull-up-Widerstand frei gegeben, also eingeschaltet.

Kann nichts Verdächtiges finden, der Garagen-Pic läuft in der Simul-Anlage, als hätte er nie was anderes als gute Arbeit abgeleistet.
Grüße, picass

picass

Um irgendwie voran zu kommen, bearbeite ich erst mal Vorhandenes – evtl. Neues muss warten. Zunächst habe ich den Funkempfänger auseinander gerupft. Gleich nach dessen Kauf hatte ich bereits das Relais raus geworfen, nun traf es alle noch verbliebenen und nicht benötigten Bauteile. Um kürzere Verbindungen zu schaffen, wurde auch die eigentliche Empfangsschaltung – die kleine Platine mit Quarz und ,,Antenne" – abgekniffen und wird dann anders wieder verlötet. Alle Elkos fliegen auch raus und werden durch solche mit geringem Innenwiderstand ersetzt. Dann kommt das Ganze in ein Metallgehäuse und dann sehen wir mal weiter.

Was mir auch nicht sehr gefällt, ist die irre Menge an ungeschirmten Leitungen in der Garage. Das fängt an bei dem Sonnenmodul und seiner langen Leitung bis zum Akku hin, das geht dann über Leitungen für Schlüsselschalter bis zur derjenigen für den Funkempfänger – auch dessen ungeschirmte Leitung zieht sich durch die ganze Garagenlänge, und die Leitungen für die Endablageschalter gibt es ja auch noch. Das Alles ist ein ganz schönes Anntennen-Equippment – das sollte eigentlich als Langwellen-Antenne eine gut brauchbare Verdrahtung sein.

Das Fehlen eines 230-V-Anschlusses bedingt so nebenher, dass auch keinerlei Erdung vorhanden ist. Daher überlege ich, ob ich eine solche Erdung nachrüste. Das wäre dann z.B. so ein Metall-Spieß, ca. 50 cm lang, den in den Boden vor der G rammen und hoffen, dass der sich auch weit genug rein rammen lässt und anschließend eine echte Erdung ermöglicht. Danach wären zumindest zwei der langen Leitungen durch Abgeschirmtes ersetzbar und die Metallgehäuse könnte angeschlossen werden. Habt ihr eine Meinung zum Sinn dieser Erdung?

Grüße, picass

pic18

von der Erdung halte ich nichts, du bist doch vom Netz getrennt?
Hast Du die Tantal Elkos und den MKT Kontensator eingelötet?
sieht komisch aus.

picass

#68
Hm..., von einer Erdung hälst du nichts? :o  "Eigentlich" gibt man sich doch recht viel Mühe, elektronische Schaltungen in Metallgehäusen unter zu bringen, sowohl, um Störstrahlungen von außen nach innen, als auch - wie in diesem Fall- zudem noch Störungen von innen nach außen abzuschirmen. Man denke an Schaltnetzteile im PC, an PC-Gehäuse überhaupt  oder z.B. die vielen, vielen Steuergeräte, die heutzutage in Kfz's stecken.

Irgendwas muss ja die PIC-Garagentorsteuerung gehörig aus der Bahn geworfen haben, irgendwas hat die Anlage veranlasst, immer wieder aufs Neue ungefragt los zu ziehen. Am Programm lags nicht, denn - wie beschrieben - arbeitet derselbe µC in der Simul-Anlage ohne jedwede Anormalität. Deshalb gehe ich davon aus, dass es externe Einflussgrößen sind. Da kann ich nur eine der eventuell Möglichen nach der anderen versuchen, zu bearbeiten, rsp. auszuschließen.

Alle "ungewöhnlich" aussehenden Kondensatoren hatte ich nachträglich eingelötet. Das "komische" Aussehen wird evtl. verständlicher, wenn man weiß, dass in dem winzigen Gehäuse eigentlich gar kein Platz für andere als Bauteile im 1204-SMD-Bauteile-Format mehr war. Das ging nur unter Quetschen und Rücksicht auf "schöne Optik" war nicht.
Die neuen Kondensatoren sind schon auf dem Wege in meine Werkstatt, und weil die dann modifizierte Platine in ein Metallgehäuse eingebaut werden wird, welches größer als das vorige Plastik-Dings ist, wird es vielleicht sogar "schöner" aussehen. Aber im Ernst: die Optik ist mir wurscht, die Schaltung soll nicht mehr so schwingen, wie sie es im orig-Zustand tat, siehe meinen Beitrag vom 26.04. um 11 Uhr.
Grüße, picass

PICkel

Habe mir den Schaltplan nochmal angesehen: Du benutzt nur die internen Pull-Up's an PORTA. Dazu schweigt sich das Datenblatt leider aus. Für PORTB werden 50...250...400 uA angegeben, was einem Widerstand von typisch 20kOhm und max. 100kOhm entspricht. So ein hochohmiger Eingang ohne weitere Entstörmaßnahmen kann bei längeren Zuleitungen schon einige Störungen einfangen.
Ich würde zumindest dem Handtaster einen zusätzlichen Pull-Up- Widerstand von 0,5...1kOhm spendieren. Die Endlagenschalter sind unkritischer, da sie nur beim Fahren des Tores abgefragt werden müssen.

Gruß
PICkel
 

picass

Zitat von: PICkel in 20.03.2023, 14:04:39 CETSo ein hochohmiger Eingang ohne weitere Entstörmaßnahmen kann bei längeren Zuleitungen schon einige Störungen einfangen. PICkel

Hallo PICkell!
Der Schaltplan entspricht nicht dem aktuell verbauten Material. Alle bis auf den genannten Port-Pin A2 hatten je einen 82 kO-R nach Plus und - is klar - der A2-er wurde nun nachbestückt. Hm..., hatte für mich bislang so'ne Grobeinteilung: alles unter 1 kO ist niederohming, ab 100 kO isses hochohming und dazwischen halt - überraschend ! - mittelohmig.
Hab's gerade mal mit meinem HP41CV nachgerechnet: du hast recht, bei 5 V und 82k fließt maximal ein sehr micromaler Strom, deutlich weniger als 1 mA. Na gut, ich werde umrüsten.

Anbei ein Auszug aus meinem heutigen Werkeln an der Garagen-Platine, der vorbereitete Text:
Heute spezielle Lötübung: Grund für die Zerspanungsaktion am Funk-Empfänger sind die Bemühungen, die ursprünglich vorhandenen wilden Eigenschwingungen zu verhindern. Dazu heute ein eher kleiner Beitrag, nämlich das Anbringen der üblichen 0,1 µF-Entkoppelkondensatoren ,,rechts" und ,,links" vom Spannungsregler-IC. Diese beiden C's sollen laut sämtlicher Vorschriften so dicht als nur möglich an den Anschuss-Pinnen – in diesem Fall drei – des Sp-Reglers angebracht werden. Nun neige ich mal wieder dazu, das wörtlich zu nehmen. Entsprechend wurden erst zwei C's im 0805-Gehäuse im rechten Winkel verlötet, dann drei ,,Haltestangen" an die besagten Pinne angebracht und die winkligen C's dazwischen gelötet.

Das übliche Flöhehüten eben mal wieder. Zudem sieht man die auch schon wieder huckepack montierte Empfangs-Platine, rsp. den Splitter von Platine mit Quarz und Antenne. Das Gewusel ist noch lange nicht beendet......
Grüße, picass

PICkel

Noch ein Tipp, um die Pins von PICs im DIL-Gehäuse beim häufigen Ein- und Ausstecken (zum Programmieren) zu schonen:
Man steckt den PIC in eine einzelne Fassung und steckt diese "Einheit" dann zwischen Programmiergerät und Zielplatine um. Verbogene oder abgebrochene Beine des IC gehören damit der Vergangenheit an.

Gruß
PICkel

picass

#72
Bin fertig mit der Funk-Welt und habe mir eine gehörige Deprise eingefangen!
Heute kam die Lieferung mit den hochwertigen Kondensatoren, welche als Letztes noch fehlten. Die also an sorgfältig ausgewählten Plätzen eingelötet, alles kontrolliert, eingeschaltet, aber so recht wollte das nicht schalten. Noch während des kontrollierenden Messens wollte die Schaltung auf einmal 40 mA, vorher nur irgendwas in der Gegend von 2 bis 4.
Dann ging eine zerstörerische Suche los nach dem Verursacher: alles, was in den letzten Tagen sorgsamst zusammen gefügt war, wobei jede Leiterbahn und jedes Bauteil auf Optimierung abgeklopft und das auch häufig umgesetzt wurde, das wurde nun Stück für Stück entweder mit dem Lötkolben oder der Beißzange zerfleddert, rsp. von der Stromversorgung abgetrennt. Zum Schluss war nur noch der Eingangsbereich übrig vom +12 V Eingang bis zum Regler-IC, alles andere war im elektrischen Jehnseits.

Einer der beiden gestern hucke-pack auf dem Regler-IC montierten 0805-SMD-Kondensatoren hatte sich einen ohmschen Widerstand, anfangs von 20 Ohm, dann von 12 Ohm eingefangen!

Die Zerstörung alle dessen, was in den letzten Tagen mit viel Mühe fast liebevoll zusammen gestaltet wurde und das auch gänzlich ohne Rücksicht auf die Zeit, lähmt mich. Ich muss das beiseite legen und ganz was anderes machen.
Grüße, picass

picass

Zitat von: PICkel in 20.03.2023, 17:13:53 CETNoch ein Tipp, um die Pins von PICs......zu schonen:
Herzlichen Dank für deine vorsorglichen Worte! Ist sicher 'ne gute Maßnahme, wenn häufige Wechsel abzusehen sind. Selbst habe ich mich seit Etlichem auf eine Methode eingeschossen, in welcher ich immer denselben Schraubendreher-Typ nutze - einen üblichen Polprüfer - und dessen Prüfspitze wechselseitig zwischen PIC-Gehäuse und Fassung schiebe, dann aber nur ein ganz klein wenig hoch hebele, die Seite wechsel und das mehrmals. Inzwischen berücksichtige ich beim Erstellen von Platinenlayouts bereits diese Hebelmethode und sorge dafür, dass keine höheren Bauteile an den Stirnseiten einer DIL-Fassung liegen.

Johannes, ach und klag.... auch die dritte Version will das Garagentor nicht hochziehen. Ist qasi wie die Vorige: es leuchten diverse für Kontrollzwecke verbaute LEDs, aber nix rührt sich, auch nicht nach Tastendruck. Es leuchten die LEDs für den Power-Mosfet, diejenige für das ganz rechts, d.h. zur Mitte der Platine hin montierte Relais und einer der beiden LEDs, welche reine Kontrollzwecke, aber keine funktionalen haben.
Mist, flixter, du bereitest dir da viel Arbeit. Bald geht es dir so wie mir gestern mit der Funktfernbedienung: Frust bis zum Abwinken.... tut mir leid, das wird auch 'ne hatte Nummer.
Grüße, picass

picass

Zitat von: picass in 21.03.2023, 11:35:57 CETEiner der beiden gestern hucke-pack auf dem Regler-IC montierten 0805-SMD-Kondensatoren hatte sich einen ohmschen Widerstand, anfangs von 20 Ohm, dann von 12 Ohm eingefangen!
Heute einen neuen Anlauf genommen, alle montierten Bauteile runter, die Platine geputzt, die Verbindung zu den "Verbrauchern" wie µC und Funkplatine unterbrochen, sodass nur noch der Spannungsregler übrig blieb. Den mit neuen und klassisch-großen Block-Kondensatoren versehen, zwei der neuen Elkos eingelötet und das war's dann. Ein erneuter Schuss in den Ofen. Es hatte nicht nur - siehe oben - einen der 0805-C's erwischt, den mit 12 Ohm, sondern auch den Regler noch. Der ließ die Eingangsspannung von 11 Volt durch.

Das bedeutete das Ende! Zum einen war das ein Regler mit gänzlich ungewöhnlicher Pin-Belegung - ein gleiches oder nur ähnliches IC konnte ich bei Reichelt nicht entdecken - und damit war ein Ersatz nahezu ausgeschlossen, und zudem weiß nun auch niemand, ob die 11 Volt nicht schon vorher durchgekommen waren und somit den µC zerschossen hatten. Nun also der Wurf in die Tonne. Das war einfach zu billiges Material.

Da ich mit den Experimenten für eine Infrarot-Fernbedienung noch gänzlich am Anfang bin und niemand weiß, wie weit das führt, habe ich nun in den sauren Apfel gebissen und erneut eine Funk-Quetsche bestellt. Diesmal von einem deutschen Händler und das auch nicht zum Dumpingpreis. Das Innenleben wird dennoch wohl Chinaware sein, aber zumindest muss es dafür die übliche Gewährleistung geben.
War 'ne erneut bittere Lektion, immerhin wird das nun die dritte F-Quetsche. Einzig Positives: es wird nicht noch weitere Zeit einem schlechten Produkt hinterher geworfen.
Grüße, picass

Schnellantwort

Achtung: In diesem Thema wurde seit 120 Tagen nichts mehr geschrieben.
Wenn Sie nicht absolut sicher sind, dass Sie hier antworten möchten, starten Sie ein neues Thema.

Name:
Verifizierung:
Bitte lassen Sie dieses Feld leer:
Geben Sie die Buchstaben aus dem Bild ein
Buchstaben anhören / Neues Bild laden

Geben Sie die Buchstaben aus dem Bild ein:

Tastenkürzel: Alt+S Beitrag schreiben oder Alt+P für Vorschau

Similar topics (2)