Rollladensteuerung altehrwürdig

Begonnen von picass, 16.10.2021, 17:01:46 CEST

Vorheriges Thema - Nächstes Thema

picass

Es gibt schon einen Fred von mir über eine in Arbeit befindliche neue Steuerung für Rollläden-Motoren. Diese Arbeit schlummert aber auf einer meiner langen Bänke. Wenig Schlummer ließ mir aktuell meine alte in meinem Haus arbeitende Rollläden-Steuerung. Die stammt aus dem letzten Jahrtausend, sie ging 1999 in Betrieb und lief bislang mit nur unbedeutenden Zickereien wirklich gut. Aber nun hatte es – wie an anderer Stelle berichtet – einen der PIC16F84 getroffen, was genau, ist noch unbekannt. Dieser Vorfall brachte mich aber recht in Fahrt, darf ich doch berechtigt den Ausfall weiterer Hardware befürchten. Als Erstes wurde meine auch über 20 Jahre alte Test-Anlage - bestehend aus allen Einzelkomponenten - versucht, in Betrieb zu nehmen. Klappte aber auch nur teilweise. Also bleibt mir kaum was anderes übrig, als dieses ganze damalige Projekt komplett neu zu bearbeiten, sowohl die Hard- als auch die Software. Begonnen habe ich mit derjenigen Platine, in welcher der defekte PIC saß, die in jedem Rollladenkasten sitzt und welche für die Steuerung des betreffenden Motors zuständig ist.
Zunächst hatte ich aus den alten Unterlagen eine passende .brd-Datei rausgesucht, und danach diese Platine komplett neu aufgesetzt, wobei zunächst fast alles beim Alten blieb, um den orig-Zustand sicher abgebildet zu haben. Im nächsten Schritt wurden dann die meisten Bauteile durch SMD-Versionen ersetzt, und aus der früher einlagigen wurde natürlich nun eine doppellagige Platine. Das Schwellwert-IC wurde auch als SMD umgewandelt, der PIC16F84 blieb jedoch gedillt. Das hatte aus meiner Sicht den Vorteil des einfacheren Handlings beim Programmieren von Test-Programmen, und zudem kann ich so einen PIC zukünftig aus einer nicht funktionierenden Steuerung fix verpflanzen in die Test-Steuerung und habe damit schnell einen Fingerzeig, wo es weiter lang gehen sollte.
Eine noch neuere Platine wurde auch noch erstellt. In der ist fast kein Stein auf dem anderen, geschweige denn alten geblieben. Nur die Optokoppler blieben, alles andere wurde umgemodelt und bei der Gelegenheit auch die Schaltung selbst überarbeitet und Überflüssiges, rsp. übertrieben vorsichtig Montiertes raus gestrichen. Und auch der PIC ist nun in SO-Version. Diese Platine wird dann zukünftig kurzerhand als Ersatz bei Reparaturen eingepflanzt.
Die Bilder zeigen ein Foto der alten orig-Platine, dann die Test-Platine mit dem PIC-DIL und die beiden letzten sind die PIC-kompletto-tutti-SMD's.
Die Aufträge an AISLER sind raus, das Anlanden der Platinen dann gegen Ende Oktober, dann bestücken, dann wieder hier vorstellen. Und dann – schwitz – beginnt die Sisiphus-Arbeit, sich wieder in das alte Assembler-Programm einzuarbeiten. Das scheint mir auch nötig zu sein, wird aber ein voll hatter Brocken für mich werden. Dunnemals hatte das ganze Rollladenprojekt ein-einhalb Jahre beansprucht.
Falls jemand Interesse an den orig-Eagle-Dateien hat, bitte melden.
Grüße, picass

Peter

Ja der Pic16c84 ist fast gar nicht mehr zu bekommen. Nur noch zu
hohen Preisen. Aber der Pic geht ja nicht ohne Grund kaputt. Hast du
da schon den Fehler gefunden ? Sonst nimmst du den Fehler auf die neue Platine mit.

picass

#2
Da hast du aber wirklich sehr aufmerksam hingeschaut, Peter! ;) Aber ein Blick auf die alte Orig-Platine zeigt, dass ich den auch nicht verwendet hatte, sondern natürlich die F-Version, also den PIC16F84. Die C-Version habe ich jetzt nur im Schaltplan genutzt, weil in meiner schon älteren Eagle-Version nur dieses Symbol implementiert ist. Mit dem Verwenden der - nenne das mal so: - kleinen Integrationsprogramme, mithilfe derer man vorgefertigte µC-Symbole z.B. von Elektronik-Großhändlern downladen und dann in die Bibliothek der eigenen Eagle-Version einfügen kann, breche ich mir immer noch alle Finger. Da bräuchte ich Hilfe. Habe mich nur noch nicht getraut, das mal in einem eigenen Fred hier einzustellen.
Nein, der Fehler im Defekt-PIC ist noch nicht gesucht, rsp. gefunden. Suche da immer noch nach einer Möglichkeit, aus dem ausgelesenen Hex-File mithilfe eines Assemblers ein vernünftig lesbares Assembler-Listening zu erhalten.
Grüße, picass
Nachtrag: habe jetzt erst in den neuen Beitrag von vloki geschaut und werde das gleich ausprobieren.

Peter

Ich kenne mich zwar nicht in Eagle aus aber kannst du nicht einfach
im Schaltplan auf den Namen klicken und einen anderen Name für das
Bauteil vergeben ? Dann stimmt es ja wieder. Der Rest ist ja dann gleich.

picass

Urlaub ist rum und das ist kein gutes Zeichen! Schon gar nicht, wenn man zuhause gleich von neuen, dräuenden Microprozessor-Probs empfangen wird: in meiner bald 20 Jahre alten Rollladensteuerungs-Anlage (RSA) kommt es doch gefühlt vermehrt zu Aussetzern. Ist auch nicht wirklich verwunderlich, ist doch zum einen der Erhalt der (Programm-) Daten für solchen Zeitraum nicht mehr garantiert, dann kann an den furchtbar vielen Kontakten (,,Silber-Schuh"-Stift und Nagel) sich doch Korrision oder eine gewisse ,,Lockerheit" einstellen und – tja – schlichte Bauteiledefekte soll es ja auch noch geben. Da muss ich wohl oder übel mal grundlegend ran. Will sagen, im Mindesten stünde an, für jede der verbauten Platinentypen passenden Ersatz anzulegen. Das ist bislang nicht passiert.

In der orig Anlage sind PIC16F84 verbaut. Am einfachsten scheint es, die Platinen einfach nochmal nach-zu-layouten und entsprechend zu bestücken. Aber der alte PIC-Typ ist natürlich längst ausgelaufen, die Reststücke werden teuer verkauft und da fragt es sich, ob der Erhalt veralteter Hardware überhaupt erstrebenswert ist. Man könnte auf den Gedanken verfallen, auf einen neueren PIC umzustellen. Das könnte der von mir geschätzte PIC18F14K22 sein, alleine...., der ist ja auch schon von Microchip nicht mehr empfohlen. Stattdessen wird auf den PIC18F24Q10 verwiesen.

Nun beschäftigen mich diverse Fragen und vorab bitte ich euch schon mal um Beratung grundsätzlicher Art, aber auch zu den einzelnen Fragen. Da wäre z.B. das Zeitkritische. Die PIC-Oldies laufen mit einem Keramik-Schwinger, die Frequenz müsste irgendwo bei 33 kHz liegen – muss mal nachschauen. Alle Programme sind auf Genauigkeit des Timings angelegt. Da werden für jede Aktion 8-bit-Wörter über die Datenleitung geschoben und dafür geregelte Impulspausen erzeugt. Eine Befehlsausgabe besteht aus dem nacheinander Versenden von ca. 12 Stück solcher 8-bit-Wörter mit jeweiligen Pausen.

Wenn ich nun einen anderen PIC nehme und die gleichen Keramik-Schwinger nicht mehr verfügbar sein sollten – im ersten Anlauf habe ich die nicht mehr gefunden - , was dann tun, um die gleiche Grundfrequenz zu erreichen? Im Programm kann nichts umgestellt werden, denn das hieße, ein gutes Dutzend an Rolllädenkästen aufzureißen, wobei nicht nur die rumfliegenden Tapetenreste der Hausfrau einen kriegsähnlichen Zustand vermitteln würden.

Sollte sich die Sache mit dem gleichen Takt erreichen lassen, dann wäre noch die Frage, ob bei der notwendigen Umstellung des Assembler-Speaches vom 16F auf einen 18F grundlegende Probs zu erwarten wären.

Ich bitte um freundlich zugedachte Stellungnahmen.
Grüße, picass

picass

Ein Prob hätte sich aufgelöst. Habe auf einer alten Platine noch so'n Kermaik-Schwinger entdeckt. Es handelt sich um den Typ "ZTB 455E". Der hat 455 kHz und ist doch noch verfügbar, wenn auch zu kurios unterschiedlichen Preisen. Aber immerhin, könnte es jetzt "beschwingt" weiter gehen.
Grüße, picass

picass

#6
Die Wiederbelebung der gut 20 Jahre alten Simul-Anlage, welche zu der im Haus verbauten Rollladensteuerung passt, rsp. passen sollte, ist gelungen. Nachdem sämtliche Verbindungen gekappt, die korridierten Silbernägel- u. Schuhe ausgewechselt wurden, nach diversen Reanimierungsarbeiten  und Test- u. Korrekturarbeiten konnte der S-Anlage ein erneutes Leben eingehaucht und per Oszi und diverser LED-Markern nachgewiesen werden. Die ersten beiden Bilder zeigen den Zustand vorher, die anderen beiden den jetztigen.
So'ne funktionstüchtige Simul-Anlage hat einen hohen Gebrauchswert. Einen Kandidaten zum Werten gibts es ja leider auch schon: ein verbautes Gerät entwickelt ein Eigenleben und legt alles andere lahm. Ähm... zumindest solange, bis das abgeknöpft wurde. Aber nun kann die Rep-Arbeit beginnen.
Die Renaturierung der Schaltpläne und der dazugehörigen Platinen-Layouts ist erst bis zum Drittel geschafft, aber das ist nun nur noch Form-, rsp. Geduldssache.

Bei die Gelegenheit: es soll ja für alle Platinen jeweils eine neue Version erstellt werden. Anstelle des PIC16F84 soll da nun ein PIC18F14Q41 rein. Das ist soweit überprüft und könnte klappen. Für alle Fälle hatte ich heute mal bei Reichelt rein geschaut. Potz donner, die haben tatsächlich noch den alten PIC16-Typ gelistet und sogar auf Lager. Während der neue µC knapp unter 2 € peilt, sollen für den Methusalem jedoch 7,50 € abgedrückt werden. Also..., wenns denn klappen sollte, lieber upgraten.
Die vielen LEDs auf der kleinen, länglichen Platine sind normal natürlich nicht verbaut, die sollen jetzt helfen, den Status der Funktionen und der Programm-Abarbeitung aufzuzeigen.
Grüße, picass

picass

#7
Im Moment ist bei mir - µC-mäßig - "Land unter". Aber so was von! :-[ Es lässt sich auch so formulieren: die Lage an der Rollladen-Front ist eskaliert!

Seit Monaten gab es zunächst Probs rein mechanischer Art, rsp. ein solches, welches nix mit meiner Elektronik-Schaltung zu tun hat: ein Rollladen will nicht runter, weil sich zwei der R.-Stäbe seitlich verschoben haben und es da hakt. Im anderen Fall gibts es Ungewöhnliches beim Hochziehen: Unter lautem Knallen zieht der Motor nur 5 cm hoch, schaltet ab, startet unter Knallen neu und das Geknalle wiederholt sich 20 mal, danach wird "normal" hochgezogen. Da wird ein neuer Motor in der Rollladen-Welle nötig sein. Mit der Beseitigung dieser beiden Probs wollte ich bis zur wärmeren Jahreszeit warten. Die ist nun da, entsprechend müsste eigentlich....
Eigentlich, denn nun meldet sich die Elektronik mit Ansprüchen. Erst fiel eine Komponente aus, eine Handsteuerung. Nach erstem Eingriff schien das gelöst, war aber nur schöner Schein, inzwischen störte das Teil die gesamte Anlage und musste außer Betrieb gesetzt werden. Das war aber nur ein harmloser Auftakt. Nun will die gesamte Anlage nicht mehr, auch die Steuerung direkt an dem "Kell-Pic" - dem Hauptsteuergerät - will nicht mehr.

Zu den beiden technischen Probs gesellen sich Fehler, rsp. auch ungünstige Umstände der frühen Vergangenheit:
- mit der Dokumentation haperte es gewaltig, die ist nicht nur lückenhaft, da fehlt Vieles. Ach ja - und Systematik war damals nix, was zu meinen Tugenden hätte zählen können.
- Die orig. Anlage wurde auf einem DOS-Computer erstellt. Es gibt noch Sicherungen aus diesen Zeiten, und ich verfüge sogar noch über zwei PCs, welche DOS-fähig sind, aber...
- die einzelnen Dateien aus Eagle sind als BRD.-Dateien - also die Board-Dateien - erhalten. Komischerweise gibt es trotz guter Sicherungen nirgends Schematik-Dateien, also diejenigen, welche den Schaltplan darstellen. Das ist jedoch nicht dramatisch, die Platinen-Layouts für neue Platinen müssen wohl eh' komplett neu aufgesetzt werden.
- mittlerweile habe ich nach der oben genannten sogar noch eine zweite Simultan-Anlage gefunden. Nur sind beide nicht vollständig, sie enthalten nicht alle verwendeten Komponenten und vor allem war keine von beiden betriebsfähig. Das lag vorwiegend an den korridierten Verbindungen. Das ist beseitigt und nun tut sich wieder was. Aber in beiden Anlagen laufen nicht die für den Betrieb notwendigen Progs, damals hatte ich für Fehlersuche Spezial-Prog-Versionen erstellt, welche andere Funktionen hatten.
- die ASM.-Dateien der MPLAB-IDE sind anscheinend noch alle vorhanden, aber........ aber da schlägt nun die mangelhafte Systematik voll durch: welches Prog gehört zu welcher Platine?

Mein damaliger Einstieg in diese Welt der Programmierung von µCs war genauso neu für mich wie auch der Umfang der Arbeiten an "reiner" Elektronik. Da habe ich jedes Rad neu erfunden und das führte zu vieeeeeelen Entwicklungsstufen bei Hardware und bei Software. Zu einigen der insgesamt fünf verschiedenen Hardware-Geräte gab es Versions-Nummern bis Einhundert. Geschätzt 15 Stufen wurden zahlenmäßig übersprungen, aber der "Rest" exisitierte tatsächlich. Und so kam es, dass in den beiden Simul-Anlagen Reststücke ganz verschiedener Hardware-Revisionen (HWR) auftauchen. Und zu jeder HWR gehört eine andere Software-Revision (SWR). Gerade in der Endphase hatte ich die Hardware auf den Kopf gestellt und mehrfach die Belegung z.B. am PIC geändert. Die drei für die verschiedenen Geräte notwendigen Programm-Versionen wurde ebenso durch gemischt. Und das alles bereitet mir eine nicht wirklich gut zu durchschauende Gemengelage.

Es wird so sein, dass ich da Hilfe von euch brauche. Die Arbeit mache ich schon selber, aber es bleibt bestimmt Raum für technische und andere Beratung. Darum bitte ich im Vorfeld.
Grüße, picass
 

Ottmar

Hallo,
sieht aus als ob Du einen kompletten Neustart hinlegen möchtest. Wie wäre es das Projekt erstmal anhand eines Ablaufdiagramms zu überdenken, bzw. zu planen?
Ich hab mal mit dem PAP-Designer (https://papdesigner.de.softonic.com/) ein Beispiel entwickelt, wie so etwas aussehen könnte.. Vielleicht hilft's
Gruß Ottmar

Ottmar


picass

#10
@Ottmar : Danke sehr für dein Bemühen! Das läuft allerdings zunächst ins Leere.
Der Grund dafür liegt am im Haus verbauten Equipment. Im Keller sitzt der ,,Kellpic", was die Steuerzentrale ist, und in jedem Rollladenkasten sitzt je ein ,,Rollpic". Im R-Kasten! Will sagen, an diese Roller und damit ggf. an ihr Programm gelangt man nur, indem man jeden Kasten öffnet. Jeden! Tapeten runter reißen, Löcher für den Zugang zu Schrauben erzeugen, Bretter von teils über 2 Metern Länge abnehmen, den entstehenden Staub schlucken und versuchen, der wütenden Hausfrau Durchhalteparolen zu vermitteln. Der Weg ist erst mal zu.
Es gibt eine hoffentlich logische Sicht auf das Prob und auch neue Hinweise auf den Sitz des Übels. Die Logik wäre, dass die in über 10 Rollpics implementierten Programme nicht alle auf einmal einen Knacks weg haben können. Immerhin haben sie 20 Jahre lang nahezu störungsfrei gearbeitet. Dieser Hinweis ist neu: Komme gerade von einer ersten Kurz-Prüfung aus dem Waschraum, in welchem der Kell-P nistet. Messungen haben gezeigt, dass der keine Bus-Signale ausgibt, schon an seinem eigenen Port-Ausgang ist da nichts. Das Eingangs-Steuersignal von der Taste ,,Rauf" kommt jedoch einwandfrei an. Nur der PIC dazwischen tut nichts.

Als nächstes wäre die Ermittlung  der Revision der beim Kell-P verbauten Platine dran und das Suchen nach der dazu passenden Software. Ist das erreicht, werde ich den Kell-P ausnisten, ihn auf meinen Labortisch verfrachten und einer gestrengen Befragung unterziehen. Anschließend gibts evtl. die Möglichkeit, ihn in einer der beiden Simul-Anlagen weiter zu testen. Und – is klar – es wird natürlich der PIC selbst über die MPLAB-X-IPE ausgelesen und versucht, dessen Hex-File mit dem  hoffentlich wieder entdeckten Orig zu vergleichen. Irgendwas wird bei dem Gestrampel schon raus kommen.

Der Kampf an anderer Front ist schon weiter. Die beiden grundlegenden und wichtigsten der 4 insgesamt vorkommenden Platinen sind soeben als Layout in Neukonstruktion fertig gestellt und via AISLER auf den Weg des P-Backens gegangen. Das war ein echtes Geschufte, da blieb nicht ein einziges Teil unbearbeitet, von den ausgetüftelten Wegen für die Leiterbahnen wollen wir besser nicht reden. Letzteres ist aber ungeachtet vom Aufwand – wie schon mal erwähnt- meine Lieblingsarbeit.

Ottmar, dein Bemühen wird aber nur in nächster Zeit in die Ecke gestellt. Sind die bestellten Platinen da, müssen die Programme reichlich Änderungen erfahren. Bei der Gelegenheit werde ich hoffentlich mich auch einer verbesserten Systematik zuwenden und für die Dokumentation solche Verlaufspläne erstellen. Sagte ich ,,verbesserte Systematik"?  ::) Überhaupt 'ne S. wäre schon ein Fortschritt. >:D
Grüße, picass

picass

#11
Nachfolgendes ist nur für die Hatten unter euch!
Es hat sich viel getan, ebenso wie nichts!
Getan:
- die Schaltungspläne und das Layoutbild liegen vor;
- die beiden funktionsgleichen Platinen (fP) aus Orig-Keller und Simul1 sind nicht exakt gleicher Revision, aber ganz dicht beieinander und – wichtig – die Portbelegung der beiden PIC-Fassungen sind absolut identisch, was die Funktion anbelangt;
- beide fP's wurden mehrfach untersucht, evtl. Mängel wie unbelegte Ports, fehlende Abblock-C's beseitigt, rsp. nachgerüstet, Überflüssiges (Kabel z.B.) entfernt und alles auf pico-bello-Stand gebracht;
- das Hex-File des orig Kellpics wurde ausgelesen und einem anderen PIC16F84 einverleibt. Der PIC in der Simul1-Anlage muss ein gleiches oder fast gleiches haben, wie die Bussignale zeigen;
- mithin stehen zur Verfügung: eine komplett funktionstüchtige Simul-Anlage, die orig Kell-Platine – also die mit dem Defekt – und drei PICs mit gleichartigem/gleichen Programm;
- die anliegenden Spannungen sowohl im Sleep-Modus als auch in Betrieb wurden gemessen und protokolliert;
- die Eingangssignale – z.B. 50 Herz – wurden im Betrieb gemessen und oszillographiert (oz), ebenso die Schwingungen des Keramik-Resonators;
- alle diese Signale sind gleich, rsp. mit absolut unbedeutenden Abweichungen, da passt alles. Zumindest aktuell.

Vorher aber wurde ein dramatisch klingender Umstand entdeckt: Das Signal für 50 Herz kam am PIC-Port mit einer Amplitude von 18 Volt an! Zwar lagen zwischen Trafo mit Gleichrichter und dem PIC noch ein R mit 10 kO, es waren aber dennoch achtzehn Volt! Trotz des Desaster hatte ich jedoch kurzfristig Freude empfunden, könnte das doch des Pudels Kern gewesen sein: Zerstörung des Eingangs mit der Folge des Fehlens dieses wichtigen Signales. Wie dieser Fehler sich einschleichen konnte, ist mir ein Rätsel. Einzige Erklärung: In der dunnemaligen Endphase ging es mit Zeichen von Erschöpfung und Stress zu. Wenn man denn was Putziges sagen möchte angesichts des Desaster: in allen anderen Schaltungen ist dieser Funktionsblock korrekt ausgeführt: das 50 Hz Signal wurde gleich zweifach eingehegt durch einen Spannungsteiler wie auch zusätzliche Z-Diode. Nur bei dieser einen Schaltung eben nicht. Das hat der PIC 20 Jahre lang durch gehalten und lebt immer noch – wie sich unten zeigt. Is klar: schnellstens wurde so eine komplexe Technik wie ein Spannungsteiler nachträglich eingefügt und jetzt touchiert ein braves 4,0 Volt – 50 Hz – Signal den PIC-Port.

Soweit, so schlecht, denn nun geht es ums Nicht-Tun:
- In der Simul1-Anlage in ,,originaler Ausstattung", also mit der Kell-PIC-Simul-Platine (KPSP), funktionieren alle 3 PICs einwandfrei und spucken – aus dem Schlummer gerissen – achtmal saubere 8-bit-Worte in die Bus-Leitung und der ,,Roll-Pic" – also der im virtuellen Rollladenkasten – wacht auf und nimmt seinerseits die Arbeit auf. So soll es sein.

- Wechselt man in der Simul1-Anlage das KPSP aus gegen das im echten Keller befindliche originale Board, dann will keiner der 3 PICs sich äußern. Die wachen auf, tun aber nichts – der Portpin bleibt kalt, rsp. verharrt auf 0 Volt. Das ist gemessen direkt am P-Pin, nicht etwa irgendwo auf der Platine! Und der Pin der Fassung hat definitiv keinen Kurzen mit irgendwas.
- Mehrfach alle statischen und dynamischen Signale geprüft. Die keramischen Schwingungen haben eine mehr als vorbildliche Sinus-Funktion mit voller  5V-Amplitude!

Jetzt brauchts hatte Männer! Also mC-mäßig Hatte! Hätte auch nichts gegen Hilfe aus weiblicher Umgebung. Mache jetzt erst mal eine Pause, denn im Moment bin ich
mit dem µC-Latein am Ende.
Grüße, picass

picass

#12
Den µC hatte ich heute weit weg gelegt. Den mit seinem verlorenen Ausgangssignal (Bus) wollte ich nicht vor Augen haben. Stattdessen hatte ich mich der schnöden Elektronik zugewandt - sprich: der Platine, immer in der stillen Hoffnung, den fetten Fehler zu finden. Gefunden - auch wenn das jetzt ein Widerspruch wird - habe ich nach etlichem Gewusel was gänzlich Fatales: ein zweites verlorenes Signal !!!!
Der Schock nach dem 20-Volt-Desaster des 50 Herz-Signals (50HS) saß mir noch in den Knochen. Den gestern eiligst eingerichteten Weg über einen Spannungsteiler wollte ich nicht so lassen, sondern - wie dunnemals geplant und auf allen anderen in diesem Rollladensystem verbauten anderen Komponenten so ausgeführt - auch auf dieser Platine das 50HS erst über einen 74HCT14 führen, einen sechsfach negierenden Schmitt-Trigger (nST). Der sollte sowohl ein sauberes Signal erzeugen als auch - hört,hört - den PIC-Eingang schützen. Und es war ja auch noch einer der sechs nST's frei. Guckeda - das war sogar im Layout angelegt, also leiterbahnmäßig, nur war die Leiterbahn zwischen nST und PIC unterbrochen und halt der Umweg über die 20-V-"Versorgung" eingerichtet. Also den ursprünglich geplanten Zustand wieder eingerichtet und - Tusch - das 50HS kam am entpsrechenden nST an, aber nicht wieder raus!!!
Da hab' ich die Krise Nummer zwei bekommen, schon das zweite verlorene Signal!!!! Verzweifelt das Layout abgesucht, das Milli-Ohm-Meter wies eine Verbindung mit 12 Milli-Ohm auf - also ein traumhafter Wert - , es gab keinerlei Bauteile auf dieser Leiterbahn und gemessen auch keinerlei Kontakt zu irgendwas! Gerade eben zur Kaffetrinkenszeit drohte mir ein Kollaps, diesmal ein elektronischer.

Die Generierung des 50HS könnt ihr auf der Handskizze sehen. Das von dieser Schaltung erzeugte Signal kommt in der Form wie auf dem Bild des Digi-Oscars dargestellt am Eingang des nST an. Warum kommt da nichts raus? Ach ja - natürlich hatte ich einen Defekt des Gatters vermutet und das eingelötete IC raus gerissen und ein anderes neues eingelötet. Ergebnis: wie vor, als wieder nur die leere Menge.  Was läuft da falsch?
Grüße, picass

Ottmar

Hi picass ,
auf welchem Weg kommen die Befehlcodes z.B. 'rauf-runter stop' zu den Rolladenpics?
Kommen von dort Rueckmeldungen (z.b. Rolladen klemmt)? 
Ich könnte mir denken dass die Befehle rein statisch sind. Z.B. 0xff rauf, 0x99 runter usw. Geschieht das seriell oder parallel? 
Im Grunde geht es wohl darum, die codes rauszubekommen. Wonach dann ein neues Programm fuer den "Kellerpic" geschrieben werden koennte.
Halte Dir die Daumen!

pic18

für was wird das 50Hz Signal benötigt? Wenn Du am Eingang vom Schmitt-Trigger eine Diode schaltest, woher bekommt der Eingang dann das Massesignal bei fallender Flanke?

Ottmar

Hi picass,
meine Anfrage habe ich größtenteils selbst beantwortet, indem ich Deine Threads zur Rolladensteuerung seit 2021 gelesen habe. Das scheint wirklich eine sehr anspruchsvolle Aufgabe für Dichzu werden. Wie gesagt, ich drücke Dir beide Daumen.
Dennoch welche Leitungen gehen den zu den Rolladenpics (PADNr.??)?
mfG Ottmar

picass

#16
Der ,,Kell-Pic" sendet seine Daten, indem er der Anzahl der verbauten ,,Roll-Pics" entsprechend viele 8-bit-Worte seriell auf den gemeinsamen Datenbus legt. Von ,,oben" (höherwertige Bits) aus runter sind die Adressen untergebracht, das ,,billigste" Bit hält die Richtung vor. Eine Rückmeldung gibt es nicht, das ist ,,one way".
Die Leitungen: es gibt eine Bus-Leitung vom PIC zu allen anderen und eine zweite BL von den Roll-Pics zurück zum K-Pic. Am K-Pic kommen die Eingangssignale auf der Platine am Punkt (PP) ,,buse" an und führen zum Pin6 /Port B,0 und der Pic versendet über den Pin7/Port B,1 und den PP ,,busa".

@Ottmar: nach meiner Logik sah die Lage so aus:
die drei Pics brachten in einem der beiden Platinen die gewünschten Funktionen, auf der anderen nicht. Das bedeutete für mich: an der Software kann es nicht liegen, wäre die ,,hinne", würde es gar nicht funktionieren. Zudem: was wurde zwischen Nicht-Funktion und Funktion geändert? Nur eines: die Hardware. Also war der Fehler just dort zu suchen. So meine Gedanken.

Der 74HCT14 (nST): sein speed, der Bezug zum GND-Level, die Schaltschwellen
Rein theoretisch dürfte das Alles nicht passieren, denn...

- er schafft eine Reaktion auf eine Leveländerung am seinem Eingang nach 5 nS !
Laut Digi-Bild verharrt das 50Hz-Signal mehr als 10 mS auf dem Grundlevel. Während des Verharrens könnte der 74-ziger tausend mal schmitt-triggern.

- der nST ist kein Nullspannungs-Schalter! Seine Funktion wird definiert durch Umschaltvorgänge auf zwei definierten Pegeln am Eingang. Die sind im Datenblatt klar definiert: 0,6 V und 2,1 V mit der Hysterese von 1,5 V. Da soll er schalten.

- der Bezug zur Masse des Eingangssignals oder auch: kann ein Digi-Oscar lügen?
Wenn der DO bei einem reinen Sinussignal, dessen eine (vertikale) Hälfte weg geschnitten wurde und der Wegschnitt – weil keine Elektronen nach kommen – über 10 mS auf der Grundlinie verharrt, diese Kleben auf GND anzeigt, dann muss die Grundung ,,in echt" auch so sein. Oder interpretiert/träumt sich der D-Oscar über seinen internen µC da gelegentlich ein Wunschergebnis zurecht?!

Auf diese Fragen/Sachverhalte hätte ich gerne eine Antwort/Erklärung, nicht nur aus technischer Neugierde. Ich möchte es verstehen können.

Die Diode, @pic18 , die Diode!!! Da haben wir beide das Gleiche gedacht, wenn auch aus unterschiedlichen Anlässen. Bei mir war es das Manöver des letzten Momentes, als so ziemlich das Letzte, was mir noch einfiel. Die Diode hatte ich (vorgestern) mit einem stabilen Draht gebrückt.
Tusch: das verlorene zweite Signal (am Ausgang des 74-zigers) war wieder da!
Tusch 2: das verlorene erste Signal (Daten aus am PIC) war wieder da!
In Worten: die komplette Schaltung nahm sofort ihre Arbeit wieder auf!
Runde Augen, usw.....

Also die D und auch gleich den R dahinter mit einem Käbelchen (sehr kurz) außer Betrieb gesetzt und die Schaltung lief und das auch mit dem 20 Jahre alten "Orig Kell-Pic". Sie muss nun natürlich noch wieder an ihren Bestimmungsort und mit den anderen Pics verkoppelt werden, Und ebenso natürlich wird ein argwöhnischer beäugter Zeitraum an Tagen vergehen müssen, um zu sehen, ob und wie.....  Aber an einen Zufall glaube ich nicht.
Passt dieser Glaube, dann war die nicht geziemende Form, rsp. Verarbeitung des 50-Herz-Signals der Belzebub. Dieses Phänomen kann ich beschreiben, verstehen aber..... räusper, und nochmal r....
Dieses Signal wird übrigens einerseits zur Syncronisation der seriellen Übertragung genutzt wie vor allem zur Erzeugung der Takt-und der Pausenzeiten in diesem Signal.
Grüße, picass

pic18_

ja das mit der Diode habe ich nicht verstanden. Da das Massesignal eigentlich am Eingang des 7414 fehlt. Wenn man am TTL-IC den Eingang offen lässt, so das Signal als HI gewertet.
Habe ich das richtig verstanden, du hast in der Schaltung nur eine Datenleitung, das Clock-Signal wird von der 50Hz Netzfrequenz abgegriffen?

picass

#18
Zitat von: pic18_ in 28.05.2023, 10:56:37 CESTWenn man am TTL-IC den Eingang offen lässt.......
In diesem Bereich muss die Antwort liegen. Der Eingang des nST liegt zwar definitiv auf Grund-Level, was auch nicht anders zu erwarten ist bei einer Eingangskapazität von nicht mehr als 15 PicoFarad und 10 mS andauerndem Ausfall an Elektronen-Nachschub. Aber die Diode koppelt offenkundig und wirksam den Eingang ab und hat eine andere Wirkung als ein einfacher Widerstand, der einseitig an GND liegt.

Eine Datenleitung: Nein, das schrieb ich oben, es gibt eine Bus-Leitung vom Kell-Pic zu allen anderen Geräten und eine zweite B-Leitung von diesen zurück zur Zentrale im Keller.
Alle Pic's generieren ihren Betriebstakt über eine eigene Takterzeugungsschaltung an ihrem Port A, in diesem Fall nicht mit Quarz, sondern mit Keramik-Schwinger (KS). Das war damals preiswerter und funktioniert genauso und zwar echt gut. Gerade auch beim Einschalten läuft das völlig reibungslos. Zudem war so'n KS damals vieeeel kleiner als die riesigen Quarz-Gehäuse.
Gänzlich unabhängig von dem KS-Betriebstakt - hier mit 455 kHz (intern wie üblich durch 4 geteilt) - wird jedem PIC von seinem eigenen 230-V-Netzteil ein geschrubbtes 50 Hz-Signal zugeführt über interne Leitung, also nicht über den Bus. Das Signal wird - wie benannt - für die Synchronisation der Kommunikation auf den Bussen benutzt.
Grüße, picass

picass

#19
Die Lage an der ,,Kell- u. Roll-PIC" – Front sieht so aus:
Gut!

Vorgestern schon hatte der kellpic sinnvolle Signale von seinem angestammten Platz aus gesendet. Gestern tat es auch der rollpic ihm nach, aber zusammen ging trotzdem nichts. Heute nun wurde der gordische Knoten der Kabel-Verknotungen gelöst – da hatte sich beim Auseinander – u. wieder Zusammenbau  was verwirrt. Aber nu' versteht und unterhält sich die gesamte Anlage wieder miteinander. Endlich. Aber so gänzlich weg ist das ,,Verwirr-Optionale" noch nicht. Mir ist schlicht kein  eindeutiger Fehler bekannt und ein defektes Bauteil hat's eh nicht gegeben. Beim kellpic wurde die Zuführung des 50-Herz-Signals (50HS) optimiert. Optimiert, mehr nicht. Denn meine zwischenzeitliche Annahme und auch Berichterstattung über die 20 Jahre angehaltene Überlastung des PIC-Ports für die Aufnahme des 50HS stimmte nicht. Nur in der Simul-Anlage war das so, im Original lag das Eingangssignal am PIC nie größer als 4,5 Volt. Also, so recht kein Grund für all den Troubel entdeckt. Aber nu' läuft es wieder und das wird hoffentlich so bleiben.

Das Gestrampel hatte aber definitiv viele gute Seiten. Mittlerweile stehe ich wieder bestens im Stoff, die fehlenden Unterlagen für die alten Schaltungen sind inzwischen neu angefertigt, und – hüstel – auch die Systematik für den Umgang mit der ganzen Anlage hat eine erkennbare Steigerung genommen. Und gerade eben trafen die von AISLER gebackenen ersten zwei Platinen ein, mithilfe derer sowohl endlich die bislang nicht vorhandenen Ersatzteil-Schaltungen erstellt werden können als auch bei der Gelegenheit auf neuere Bausteine – also neuer PIC-Typ, SMDs u. Diverses – umgeswitscht werden kann.

Fehlt nicht noch was? Klar man, die Programme. Da bin ich noch bei ersten Vorarbeiten, um die Werkzeuge für die Prog-Bearbeitung bereit zu legen. Zum Beispiel hatte mich der schlichte Ausdruck der alten Programm-Files (.asm) gequält, weil die Ausdrucke via MPLAB-X-IDE (MXI) völlig unbrauchbar waren. Da ließen sich weder die Buchstabengröße noch die Breite der Seite in sinnvolle Zusammenhänge bringen. Und der Ausdruck via Textverarbeitungs-Prog war noch schlimmer, weil die Zeilenumbrüche und die Leerzeichen wahllos durcheinander waren und eine Korrektur eine tagelange Sisiphus-Arbeit geworden wäre. Heute wurde auch da zugeschlagen: das MXI vers.5.20 wurde gekillt und die letztmögliche ver.5.35 installiert. Und gucke da, plötzlich ist der Ausdruck über dessen Oberfläche auch wieder möglich, rsp. verwertbar. Wehe, die Roll-Anlage wagt es, nochmal zu spinnen. Dann..... , dann wird Alles zubetoniert.
Oder so ähnlich.
Grüße, picass

Schnellantwort

Achtung: In diesem Thema wurde seit 120 Tagen nichts mehr geschrieben.
Wenn Sie nicht absolut sicher sind, dass Sie hier antworten möchten, starten Sie ein neues Thema.

Name:
Verifizierung:
Bitte lassen Sie dieses Feld leer:
Geben Sie die Buchstaben aus dem Bild ein
Buchstaben anhören / Neues Bild laden

Geben Sie die Buchstaben aus dem Bild ein:

Tastenkürzel: Alt+S Beitrag schreiben oder Alt+P für Vorschau

Ähnliche Themen (1)

Begonnen von picass